トラブルシューティング

 

ServiceDesk Plusの資産モジュールで、ワークステーションのスキャン実行時に問題が発生した場合のソリューションを提示します。

  1. ユーザから拒否されたかIT資産におけるリモートDCOMオプションが無効にされている可能性があります (Either access denied for the user or the remote DCOM option might be disabled in the workstation)

  2. ユーザはこのオペレーションを実行するアクセス権限をもっていません (User does not have the access privileges to perform this operation)

  3. サーバマシーンにおいてリモートDCOMオプションが無効にされています (Remote DCOM option is disabled in the Server machine)

  4. ワークステーションのRPCサーバへの接続に失敗しました (Connection to RPC server in the workstation failed)

  5. WMIコンポーネントの一つが正確に登録されていません (One of the WMI components is not registered properly)

  6. ワークステーションのWMIサービスにおける実行の失敗です (Execution failure in the WMI Service of workstation)

  7. ワークステーションのWMIサービスが無効にされています (WMI Service is disabled in the workstation)

  8. ワークステーションによってスキャンオペレーションのリクエスト拒否されました (Request for scan operation rejected by the workstation)

  9. ワークステーションにおけるTelnetサービスへの接続に失敗しました (Connection to Telnet Service in the workstation failed)

  10. ワークステーションのユーザ名またはパスワードが間違っています (Either Username or Password is incorrect in the workstation)

  11. スキャン実行時のタイムアウトです (Scan operation Timed out)

  12. 呼び出されたオペレーションは現在のプラットフォームではサポートしていません (The operation invoked is not supported in the current platform)

  13. オペレーション実行中の一般的な失敗です (General failure while performing the operation)

エラーメッセージ

ユーザから拒否されたかワークステーションにおけるリモートDCOMオプションが無効にされている可能性があります。

原因

このエラーメッセージは、以下のいずれかの理由でWindows ワークステーションのスキャンに失敗した時に表示されます。

  1. スキャンで指定したワークステーションのログイン名とパスワードが無効である。

  2. スキャン対象のワークステーションにおいて、リモートDCOMオプションが無効になっている。

回答

  1. ログイン名とパスワードが正しく入力されているか確認してください。

  2. スキャンするワークステーションでリモートDCOMが有効になっているか確認してください。 リモートDCOMが無効の場合は、有効にします。

    Windows 2000のマシンでDCOMを有効にする方法は次の通りです。

    1. スタート > ファイル名を指定して実行 を選択します。

    2. テキストフィールドに DCOMCNFG と入力します。

    3. OKをクリックします。

    4. 「既定のプロパティ」タブを選択します。

    5. "このコンピュータ上で分散COMを有効にする"というチェックボックスをチェックします。

    6. OKをクリックします。

    WindowsXPのマシンでDCOMを有効にする方法は次の通りです。
    1. スタート > ファイル名を指定して実行 を選択します。

    2. テキストフィールドに DCOMCNFG と入力します。

    3. OKをクリックします。

    4. コンポーネントサービス > コンピュータ > マイコンピュータ で右クリックします。

    5. プロパティをクリックします。

    6. ポップアップしたフレームで「規定のプロパティ」というタブを選択します。

    7. "このコンピュータ上で分散COMを有効にする"というチェックボックスをチェックします。

    8. OKをクリックします。

  3. スキャン対象のワークステーションでユーザアカウントが有効かどうかを確認します。 サーバマシンのコマンドプロンプトで次のコマンドを実行します。

    net use \\<RemoteComputerName>\C$  /u:<DomainName\UserName>  "<password>"
    net use \\<RemoteComputerName>\ADMIN$  /u:<DomainName\UserName>  "<password>"

    <>内は適切な値に置き換えてください。 引用符内("")にはパスワードを指定します。

これらのコマンドでエラーメッセージが表示される場合は、指定したユーザアカウントがスキャン対象のワークステーションで有効ではありません。

 

Top

 

エラーメッセージ

ユーザはこのオペレーションを実行するアクセス権限をもっていません。

原因

スキャンの実行に指定したユーザIDが十分なアクセス権がない場合、このようなメッセージが表示されます。 ユーザがワークステーションのAdministratorsグループに所属していない可能性があります。

回答

ワークステーションのAdministratorsグループにユーザを移動するか、管理者(ドメイン管理者)アカウントを使用してスキャンを実行します。

 

Top

 

エラーメッセージ

サーバマシーンにおいてリモートDCOMオプションが無効にされています。

原因

リモートDCOMオプションが、ServiceDesk Plusサーバにおいて無効に設定されている可能性があります。

回答

ServiceDesk Plusは、リモートのワークステーションをスキャンするために、Windows Management Instrumentation (WMI) を使用します。 WMIはリモートDCOMを使用するため、リモートマシンをスキャンするにはこのオプションを有効にする必要があります。

 

WindowsシステムでDCOMを有効にする方法は、Either access denied for the user or the remote DCOM option might be disabled in the workstationを参照してください。

 

Top

 

エラーメッセージ ワークステーションにおけるRPCサーバへの接続に失敗しました。

原因

このメッセージはスキャン対象のワークステーション上でファイアウォールが設定されている場合に表示されます。 Windows XP (SP2)でデフォルトのWindowsファイアウォールが有効になっているとき、このような例外が発生します。

回答

ワークステーションのデフォルトのファイアウォールを無効にします。 Windows XP(SP2)でファイアウォールを無効にする方法は次の通りです。
  1. スタート > ファイル名を指定して実行 を選択します。

  2. テキストフィールドに Firewall.cpl と入力します。

  3. OKをクリックします。

  4. 「一般」タブにて、無効をクリックします。

  5. OKをクリックします。

ファイアウォールを無効にできない場合、スキャン対象ワークステーションのリモート管理者の機能を起動します。 以下のコマンドを対象のコンピュータで実行すると、機能を有効にできます。

 

netsh friewall set service RemoteAdmin
 

以下のコマンドを使用すると、コンピュータのスキャン後、リモート管理者の機能を無効にできます。 機能を無効にするコマンド:

 

netsh friewall set service RemoteAdmin disable

 

Top

 

エラーメッセージ WMIコンポーネントの一つが正確に登録されていません。

原因

このメッセージは、スキャン対象のWindowsワークステーションでWMIが利用できない場合に表示されます。 このメッセージが表示されるOSは、Windows 9x、Windows NT、Windows MEです。 また、WMIコンポーネントが適切に登録されていない場合は、上位バージョンのWindowsでも発生する可能性があります。

回答

WMIをスキャン対象のワークステーションにインストールします (Microsoftウェブサイトからダウンロード)。 WMIコンポーネントの登録に問題がある場合は、コマンドプロンプトで以下のコマンドを実行してWMI dllを登録してください。

winmgmt /RegServer

 

Top

 

エラーメッセージ ワークステーションのWMIサービスの実行の失敗です。

原因

リモートワークステーションで動作しているWMIサービス(winmgmt.exe)に内部実行エラーがある場合、このようなエラーメッセージが表示されます。 ワークステーションのWMIリポジトリの最新の更新が失敗した可能性があります。

回答

以下の手順を実施し、 リモートワークステーションでWMIサービスを再起動してください。

  1. スタート > ファイル名を指定して実行 を選択します。

  2. テキストフィールドに Services.msc と入力します。

  3. OKをクリックします。

  4. ポップアップサービスウィンドウから"Windows Management Instrumentation"を選択後、右クリックします。

  5. 再起動をクリックします。

 

Top

 

エラーメッセージ ワークステーションにおけるWMIサービスが無効にされています。

原因

このエラーメッセージは、WMIサービス(winmgmt.exe)がスキャン対象のワークステーションで有効でない場合、表示されます。

回答

WMIのプロパティを無効から手動または自動に修正します。

  1. スタート > ファイル名を指定して実行 を選択します。

  2. テキストフィールドに Services.msc と入力します。

  3. OKをクリックします。

  4. ポップアップサービスウィンドウから"Windows Management Instrumentation"を選択後、右クリックします。

  5. プロパティをクリックします。

  6. スタートアップの種類が"無効"の場合、"自動/手動"に変更してサービスを開始します。

  7. サービスを再起動します。

 

Top

 

エラーメッセージ スキャンオペレーションのためのリクエストがワークステーションによって拒否されました。

原因

対象ワークステーションのレジストリのDCOM設定により、スキャンのリクエストが拒否されました。

回答

以下の手順でレジストリキーを編集します。
  1. Regeditを使用して HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\OLEに移動します。

  2. EnavleDCOMの文字列(REG_SZ)データ型の名前の値をダブルクリックします。 既にYが設定されている場合でも、値のデータをYに設定します。

  3. OKをクリックします。

  4. コンピュータをシャットダウンして再起動します。

 

Top

 

エラーメッセージ ワークステーションにおけるTelnetサービスへの接続に失敗しました。

原因

Telnetサービスがスキャン対象ワークステーションで動作していない、または、サービスが既定のポート23で実行されていない可能性があります。

回答

ServiceDesk Plusは、リモートのLinuxマシンをディスカバリする場合、Telnetを使用します。 Telnetがリモートワークステーションにおいてデフォルトポート:23で実行している必要があります。

 

Top

 

エラーメッセージ ワークステーションにおいて、ユーザ名またはパスワードが間違っています。

原因

リモートのワークステーションをスキャンするのに指定したユーザ名とパスワードが正しくありません。

回答

ServiceDesk Plusは、リモートのLinuxマシンをディスカバリする場合、Telnetを使用します。 対象のワークステーションとTelnet接続できる有効なユーザ名とパスワードを指定してください。

 

Top

 

エラーメッセージ スキャン実行時のタイムアウトです。

原因

対象のワークステーションが規定の制限時間内に応答しませんでした。 ネットワーク遅延の可能性があります。

回答

しばらく時間を置いた後、ワークステーションのスキャンを再度実行します。 再度ワークステーションのスキャンに失敗するようであれば、こちらのフォームよりご連絡をお願いします(保守契約締結済みの場合のみ)。

 

Top

 

エラーメッセージ 呼び出されたオペレーションは現在のプラットフォームではサポートしていません。

原因

このエラーコードは、WindowsとLinux以外のOSのワークステーションである場合に表示されます。

回答

ServiceDesk Plusのネットワークディスカバリでは、WindowsまたはLinuxマシンのみサポートしています。

 

Top

 

エラーメッセージ オペレーション実行中の一般的な失敗です。

原因

ワークステーションのスキャン中に何らかの予期しない例外が発生しました。

回答

http://www.manageengine.jp/support/からサポートを依頼してください。 サポートファイルは、サポートタブ -> サポートファイルリンクより作成可能です。

 

Top



ServiceDeskPlus - ヘルプデスクと資産管理ソフトウェア

Copyright c , ゾーホージャパン株式会社. All Rights Reserved.
ManageEngine