【既知の問題】Red Hat のパッチ管理で、AWS上のインスタンスを指定システムに設定すると同期に失敗する
作成日:2024年12月25日 | 更新日:2025年1月8日
【影響】
Endpoint Central サポート中のすべてのビルド ビルド番号の確認方法はこちら、サポート中のビルドはこちらをご覧ください。(参考)SCAに移行した Red Hat Enterprise Linux のパッチ管理に対応するビルドSCAに移行したRed Hat Enterprise Linuxを対象にパッチ管理を実施する場合、Endpoint Central 11.3.2400.33 以降のビルドにおいて対応しています。詳細はこちらのナレッジをご覧ください。
SCAに対応したEndpoint Central 11.3.2400.33は、本問題の影響を受けます。
【問題】
Endpoint Central 11.3.2400.33 を使用して Red Hat Enterprise Linux(RHEL)のパッチ管理を実施する際、指定システムとしてAWS上のインスタンスを指定すると、指定システムの同期に失敗することがあります。 なお、この問題は以下の場合は発生しません。- Azure上のインスタンスの場合
- AWS上のRed Hat Enterprise Linusを管理する際に、指定システムをAWSのインスタンス以外に設定した場合
【原因】
以下の2つの原因により、同期に失敗します。- Endpoint Centralは、Red Hatのリポジトリの一部をサポートしています。AWS上のインスタンスを指定システムに設定すると、無効化された Red Hat リポジトリを優先的に参照しようとして、同期に失敗することがあります。
- debugリポジトリが redhat-rhui.repo において有効化されている場合、Endpoint Centralは debug以外のリポジトリのキャッシュを、debugデバッグリポジトリ用の証明書を使用して取得しようとすることがあります。この場合、証明書が有効ではないため認証に失敗し、同期にも失敗します。