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構成のステータスが「進行中」のまま変化しない


本記事では、構成のステータスが「進行中」のまま変化しない事象の原因ならびに解決策を記載しています。

構成のステータスが「進行中」のまま変化しない

進行中ステータスについて
構成が 「進行中」のステータスになると、該当の構成が1台以上のコンピューター(またはユーザー)に適用されます。
対象にしたすべてのコンピューター(またはユーザー)に正常に適用された場合のみ、ステータスが 「実行済み」 に変わるため、構成一覧上において、該当構成のステータスが 「進行中」 のままである場合は、1台以上のコンピューター(またはユーザー)に適用されていないことを意味します。
その他のステータスについては、こちらのナレッジをご覧ください。
事象

構成の状態が「進行中」のままで変化しません。

原因

複数の可能性が考えられます。

  • (A) 構成を適用している対象がWorkgroup環境の場合
  • (B) エージェントのバージョンが最新ではない場合
  • (C) エージェントが設定情報をまだ取得していない場合
  • (D) 構成の適用対象にダミーコンピューターオブジェクトが含まれている場合
  • (E) 対象のコンピューターにEndpoint Central Cloudエージェントがインストールされていない場合
  • (F) 構成の適用対象にしたユーザーの属しているリモートオフィスと、設定を適用しているリモートオフィスが異なる場合
解決策

原因に応じた対策を実行します。

  • (A) 構成を適用している対象がWorkgroup環境の場合
    ユーザー構成をワークグループに適用した場合、仕様上ステータスは「進行中」のままになります。これは、ワークグループで管理されているユーザーに対して、構成が適用されているかどうかの情報を Endpoint Central Cloud が受信できないためです。
    この現象はワークグループの仕様でもあるため解決策はありませんが、構成のステータスを適切な状態にしたい(成功済み)場合、対象となるユーザーでカスタムグループ機能を用いて、任意のグループを作成することを推奨します。構成をカスタムグループ単位で適用すれば、Endpoint Central Cloud は対象のユーザー情報を把握可能であるため、構成が対象すべてのユーザーに適用されれば、ステータスが「成功済み」になります。
     
  • (B) エージェントのバージョンが最新ではない場合
    Endpoint Central Cloud に対して、エージェントが更新されておらずバージョンが適切でない場合、適用しようとした構成は 「進行中」 のままになります。エージェントタブ > 管理対象 の概要から、構成が適用されていないコンピューターのエージェントのバージョンを確認します。エージェントは、自動的に更新されます。サーバーとエージェントの通信に問題がないことを確認し、しばらくお待ちください。エージェントのバージョン確認方法はこちらをご覧ください。
     
  • (C) エージェントが設定情報をまだ取得していない場合
    エージェントの最終連絡時刻が構成の作成時刻より後であることを確認します。確認方法は、構成の対象の種別(コンピューター構成/ユーザー構成)により異なります。

    コンピューター構成の場合
    1. 「構成」タブ > 該当構成の構成名 をクリック
    2. 「概要」タブ内の「構成の詳細」より構成の作成時間を確認
    3. 「実行状態」タブをクリックし、「最終連絡時刻」を確認
    ユーザー構成の場合
    1. 「管理」タブ >管理対象 > 「PC」タブ をクリック
    2. 該当ユーザー所有のコンピューターの最終連絡時刻を確認

     

    エージェントの最終連絡時刻が構成の作成時刻以前だった場合、次のリフレッシュサイクルまでエージェントとの通信はありません。そのため、このままですと構成を適用した時刻から最大90分間の待ち時間が生じます。構成を即時適用したい場合は、構成の適用対象PC側から次の操作を実行します。

    1. Endpoint Central Cloud エージェントがインストールされているコンピューター上で、Windows:通知領域(トレイアイコン)のEndpoint Centralアイコンを右クリック / Mac:ステータスメニューバーのEndpoint Centralアイコンをクリック します。
    2. 「構成を適用」(「Apply Configurations」)を選択する
    3. 上記の操作で実行されない場合や、トレイアイコン上にEndpoint Centralアイコンが表示されない場合は、次の操作を実行します。
    4. コマンドプロンプトを開きます。
    5. Endpoint Central Cloudでエージェントのbinフォルダに移動します。

      (例) cd C:\Program Files (x86)\DesktopCentral_Agent\bin

    6. cfgupdate.exeを実行します。

      cfgupdate.exe

     

  • (D) 構成の適用対象にダミーコンピューターオブジェクトが含まれている場合
    構成を適用する対象を OU/ドメイン にしている場合、対象のOU/ドメインにダミーコンピューターオブジェクト(OU/ドメイン内に既にオブジェクトとして存在していないコンピューター)が含まれていないかを確認してください。ダミーコンピューターが含まれている場合は、ステータスが「進行中」のままとなります。Active Directory をクリーンアップし、ダミーあるいは未使用のコンピューターオブジェクトを削除します。またはカスタムグループ機能を用いて、該当構成を適用するグループを作成し、そのグループに対して構成を適用します。構成が対象すべて正常に適用されれば、ステータスが「成功済み」になります。
     
  • (E) 対象のコンピューターに Endpoint Central Cloud エージェントがインストールされていない場合
    構成を適用する対象の中に、Endpoint Central Cloud エージェントがインストールされていないコンピューターがある可能性があります。「管理」タブ > 管理対象 > 「PC」タブをクリックし、構成適用対象ののコンピューターにエージェントがインストールされているかどうか確認してください。
     
  • (F) リモートオフィスに対して構成を適用する場合
    リモートオフィス単位で構成を配布している場合、ステータスが「進行中」のままとなります。
  • 以上が、構成のステータスが「進行中」のまま変化しない事象の原因ならびに解決策になります。