エージェントのアンインストール - Desktop Centralエージェントをアンインストールできない
作成日:2020年3月6日 | 更新日:2020年12月8日
エージェントのアンインストール - Desktop Centralエージェントをアンインストールできない
問題内容
Desktop Centralエージェントを、Desktop Centralコンソール画面(管理タブ > SoM設定 > PC)からアンインストールしようとしても実行されません。
原因
- 「アンインストール」ではなく「管理対象を削除」を選択している(「管理対象を削除」の場合、アンインストールが実行されるのは次のリフレッシュサイクルとなります)
- Mac/Linuxエージェントのアンインストールを実行する際、管理タブ > グローバル設定 > エージェント設定 > MacエージェントまたはLinuxエージェントにおいて、正しい資格情報を選択していない(アンインストール時にも認証情報が必要となります)
- ファイアウォールやアンチウイルスソフトなど、何らかの原因で通信やアンインストールプロセスがブロックされている(Windowsエージェントの場合はWindowsネットワーク設定の「ファイルとプリンターの共有」が有効化されている必要があります。Mac/Linuxエージェントの場合は、エージェント側ポート22との通信が開放されている必要があります)
- エージェントとサーバー間の通信ができない(IPアドレスではなくホスト名を用いてアクセス可能である必要があります)
解決策
- 次のリフレッシュサイクルを待ちます
- 正しい資格情報を設定します
- Mac/Linuxエージェントのポート22を開放します。また、その他の要因で通信やアンインストールプロセスがブロックされていないことを確認します
- サーバー側から、エージェントのホスト名やFQDNを用いてpingが通るかどうかを確認し、DNSやhostsファイルなどの設定を確認して名前解決が正しく行われることを確認します
上記の手順を実行してもアンインストールが失敗する場合、以下の方法を試行します。
- (A) ユーザーにクライアントコンピューターからのエージェントアンインストールを許可し、各端末でアンインストールを実行する
- (B) コマンドを用いてアンインストールする
- (C) Active Directoryドメイン環境の場合、GPOスクリプトを利用してアンインストールする
(A) ユーザーにクライアントコンピューターからのエージェントアンインストールを許可し、各端末でアンインストールを実行する
エージェントとサーバーの通信ができない状態の場合は、こちらの方法を実行します。この方法では、対象のクライアントコンピューターから操作し、手動でエージェントをアンインストールします。
- Windowsエージェントの手動アンインストール
Windowsエージェントにおいて、ユーザーにエージェントアンインストールの権限を制限している場合は、制限を無効にします。手順は以下の通りです。- 管理タブ > SoM設定 > エージェント設定 へ移動し、「エージェントセキュリティ」にある編集アイコンをクリックします。
- セキュアログインを確保 にある 「エージェントをアンインストールする権限の制限」 > 無効 をクリックします。
次のエージェントとサーバー間で通信が行われる際、この更新が反映され、ユーザーの「プログラムの追加と削除」項目に「アンインストール」のオプションが表示されます。
各ユーザーは、Windowsスタートメニュー > コントロールパネル > プログラムの追加と削除 を開き、ManageEngine Desktop Central AgentのアンインストールをクリックしてWindowsエージェントをアンインストールします。
- Macエージェントの手動アンインストール
Mac端末におけるDesktop Centralエージェントのアンインストール方法は以下の通りです。- 管理対象の端末に管理者としてログインし、ターミナルを開きます。
- /Library/DesktopCentral_Agent/uninstall ディレクトリを開きます。
- ‘sudo chmod 744 uninstall.sh’ と入力し、管理者のパスワードを入力します。
- ‘sudo ./uninstall.sh’ と入力します。
- Linuxエージェントの手動アンインストール
Linux端末におけるDesktop Centralエージェントのアンインストール方法は以下の通りです。- 管理対象の端末に管理者としてログインし、ターミナルを開きます。
- /usr/local/desktopcentralagent ディレクトリを開きます。
- ‘chmod +x RemoveDCAgent.sh’ と入力し、管理者のパスワードを入力します。
- ‘sudo ./RemoveDCAgent.sh’ と入力し、エンターキーを押します。
(B) コマンドを用いてアンインストールする
- Windows コンピューター用
- 「UnInstallDCAgent.txt」をダウンロードし、「dcagentuninstall.vbs」に拡張子を変更します。
- 以下のコマンドを実行して、エージェントがアンインストールできることを確認します。
CSCRIPT UnInstallDCAgent.vbs
- Linux コンピューター用
- 「LinuxAgentRemove.zip」をダウンロードし、解凍します。
- カスタムスクリプト機能を用いて、このスクリプトをリポジトリに追加します。
スクリプト名: 「参照」から解凍したファイルを選択
引数: &
終了コード: 0 - スクリプトをLinux端末に配布し、Desktop Centralエージェントをアンインストールします。
※ 以前のファイルは、現在のビルドに対してはご利用いただけません。
(C) Active Directoryドメイン環境の場合、GPOスクリプトを利用してアンインストールする
こちら(英語)をご覧ください。