Endpoint Central オンプレミス版 ナレッジベース

【既知の問題】Red Hat Enterprise Linuxのパッチ管理において、パッチのダウンロードやシステム登録に失敗する


この記事では、Endpoint Central(オンプレミス版)のパッチ管理機能を使用してRed Hat Enterprise Linuxを管理する際に発生する問題について説明しています。

Red Hat Enterprise Linuxのパッチ管理において、パッチのダウンロードやRed Hatアカウント登録に失敗する

確認ビルド

Endpoint Central 11.3.2400.33

問題

以下のような問題が発生します。

  • Red Hat Enterprise Linuxのパッチを配布しようとすると、Red Hatからのパッチのダウンロードにすべて失敗し、配布にも失敗します。
  • 「Red Hat Linuxの設定」において、Red Hatアカウントの登録に失敗します。
Endpoint Central 11.3.2400.33より古いバージョン・ビルドではSCAに対応していないため、「Red Hatサブスクリプションがアクティブではありません」というエラーが発生し、エラーが発生した管理対象Red Hatマシンへのパッチスキャンやパッチ配布が実行できません。まずEndpoint Central 11.3.2400.33へアップグレードを実行し、このナレッジをご確認ください。
原因

Red Hatサイトの仕様が変更されたことにより、Endpoint CentralがRed Hatサイトにログインできず、パッチのダウンロードやアカウント登録に失敗します。

回避策

サポートにお問い合わせください。必要なファイルをお送りします。
その後以下の手順を実行して、修正ファイルを適用します。

  1. Endpoint Centralサーバーマシンにアクセスし、スタートメニュー→Services.mscを起動し、Endpoint Centralサーバーサービスを停止します。
  2. <サーバーフォルダー>/lib/downloadTool/1020_Download_Tool をエクスプローラーで開き、既に存在する ExternalDownloader_64.dll と ExternalDownloader_64.h のファイル名を ExternalDownloader_64.dll や ExternalDownloader_64_old.h など、別名に変更します。
  3. サポートから受領したファイルをダウンロードし、7-zipなどを使用して解凍します。
  4. 解凍したフォルダー内のファイルのうち、ExternalDownloader_64.dll と ExternalDownloader_64.h について<サーバーフォルダー>/lib/downloadTool/1020_Download_Tool内にコピーします。
  5. 続いて、解凍したフォルダー内にある UpdateExternalToolChecksum.xml を <サーバーフォルダー>\bin 内にコピーします。
  6. コマンドプロンプトを管理者として実行し、cdコマンドで <サーバーフォルダー>\bin に移動します。
  7. 次のコマンドを実行します。

    ExecuteQuery.bat UpdateExternalToolChecksum.xml

  8. しばらく待つと、ユーザー名の入力が求められます。Endpoint Centralにログインする際の管理者ユーザー名、パスワード、ドメイン名(AD認証情報でログインしている場合のみ。ローカル認証の場合はドメイン名に何も入力せずエンターキーを押します)を入力します。
  9. しばらく待ち、実行が成功したこと(「Executed the query successfully.」が表示されること)を確認します。
  10. コマンドプロンプトを閉じ、Services.mscからEndpoint Centralサーバーサービスを開始します。
  11. 再度Red Hatのパッチ配布やアカウントの登録を試行し、ダウンロードやアカウントの登録が成功することを確認します。
修正予定ビルド

今後リリースされる日本国内向けビルド(Endpoint Central 11.3.2440.1以降)において、Red Hatのパッチ管理の仕組みが大幅に変更されます。それに伴い、本問題も修正される予定です。