【修正済】一部のPCのインベントリ情報が反映されない
【対象ビルド】
Desktop Central 10.0.558以前のビルド
【問題】
Desktop Centralエージェントをインストールし、管理タブ > SoM > 管理対象 > PC の一覧および パッチタブ > システム の一覧にはPCが表示されるにもかかわらず、インベントリタブには表示されません。
【原因】
管理対象PCにインストールされたアンチウイルスソフト(セキュリティソフト)のベンダー名が、Desktop Centralのアンチウイルスソフトベンダーカラムに設定された文字数の上限を超えており、情報が正しく反映されないため、インベントリ情報が登録できません。
【解決策】
Desktop Central 10.0.562以降へアップグレードします。
または、以下の回避策を実行します。
アンチウイルスソフトベンダーに関するカラムの文字数上限を変更する方法。
- resetAntivirusManufacturer.zipをダウンロードし、解凍してresetAntivirusManufacturer.xmlを取り出します。
- resetAntivirusManufacturer.xmlを、 <Desktop Central サーバーインストールディレクトリ>\bin にコピー&ペーストします。
- コマンドプロンプトを開き、<Desktop Central サーバーインストールディレクトリ>\bin に移動します。
- 次のコマンドを実行します。
"ExecuteQuery.bat resetAntivirusManufacturer.xml"
- スタート > ファイル名を指定して実行 > Services.msc を開き、ManageEngine Desktop Central Serverを再起動します。
以上の手順で、アンチウイルスソフトベンダーに関するカラムの文字数上限を変更しました。
改めてインベントリスキャンを実行すると、管理対象PCのインベントリ情報が反映されます。
【修正予定ビルド】
Desktop Central 10.0.558以降