フロープロトコルを有効化後フロー情報またはインターフェースが表示されない
作成日:2024年9月5日 | 更新日:2025年4月14日
現象
監視対象装置のフロープロトコルを有効化後、フロー情報またはインターフェースが製品GUIに表示されない。
原因
NetFlow Analyzerは、受信したフローデータ内の情報から装置やインターフェースを識別し製品GUIに表示します。
監視対象装置のフロープロトコルを有効化後、フロー情報またはインターフェースが製品GUIに表示されない場合、
以下のような原因が考えられます。
- フロープロトコルの宛先設定に問題がありフローデータがサーバーに到達していない
- NetFlow Analyzerの受信ポート設定に問題がありフローデータの受信ができていない
- フローデータは受信できているがNetFlow Analyzer側で監視対象として設定できていない
- フローデータ内の情報に不足分がある
解決方法
装置とNetFlow Analyzerの設定を確認
該当装置で設定中のフローデータ宛先IPアドレスと宛先ポートが、NetFlow AnalyzerインストールサーバーのIPアドレスと待ち受けポート(デフォルト値9996)であることをご確認ください。
こちらのコンフィグはあくまでサンプルであり、現在は有効ではない可能性があります。
監視対象機器の設定に関して、最終的にはお客様ご自身でベンダー様やメーカー様にお問い合わせいただく必要があります。
装置側で設定中のフローデータ宛先ポート番号がNetFlow Analyzerのサーバー設定で解放されていることをご確認ください。
NetFlow Analyzerインストールサーバーでパケットキャプチャを実行し、受信状況をご確認ください。
NetFlow Analyzer上の監視対象装置を確認
[設定]→[フロー解析]→[ライセンス管理]より製品GUI上に表示させたいインターフェースが[管理対象外インターフェース]/[新規インターフェース]に存在していないことをご確認ください。
該当インターフェースが[管理対象外インターフェース]/[新規インターフェース]に存在する場合、それらのインターフェースは監視対象外となっており、製品GUI上に表示されません。
画面右上の[管理]から、[管理対象インターフェース]に追加してください。
該当インターフェースが[管理対象外インターフェース]/[新規インターフェース]に存在しない場合、以下の「上記確認後も解決しない場合」にお進みください。
上記確認後も解決しない場合
NetFlow Analyzerのビルド番号がサポート対象であることをご確認ください。
NetFlow Analyzerのビルド番号がサポート対象である場合
保守サポートへお問い合わせください。
お問い合わせいただく場合は、本ナレッジを参照した旨をご連絡ください。
その後サポートより依頼がありましたら、以下の情報を共有してください。共有方法はこちらをご参照ください。
- NetFlow Analyzerインストールサーバーでパケットキャプチャ(Wireshark/tcpdump/tsharkなど)を5分間実行し、取得したpcapファイル
- [設定]→[フロー解析]→[ライセンス管理]より[管理対象外インターフェース]/[新規インターフェース]のスクリーンショット
- サーバー設定画面のスクリーンショット
- 問題のあるネットワーク装置のIPアドレス
- フローデータの宛先ポート
- 問題のあるインターフェースのifindex値
いただいた情報を元に、原因調査を行わせていただきます。
NetFlow Analyzerのビルド番号がサポート対象でない場合
最新ビルドでの再現性をご確認ください。引き続き同様の事象が発生する場合、保守サポートまでお問い合わせください。