SSL証明書がADで見つからないか、指定のポート番号が到達不能です。
作成日:2020年3月11日 | 更新日:2025年9月11日
このナレッジでは、「SSL証明書がADで見つかりません」(SSL certificate not found in AD)や「指定のポート番号が到達不能です」(The specified port number is not reachable)というエラーメッセージの解消の方法について記載いたします。
【事象】
「管理」タブ →「ドメイン」→「ドメインの追加」ページで、「SSL証明書がADで見つからりません」や「指定のポート番号が到達不能です。」というエラーが表示されます。
【原因】
次の2つの原因が考えられます。
- A. Endpoint Centralサーバーから指定したポートでADサーバーにアクセスできない
- B. SSL証明書がActive Directoryにインストールされていない
【【解決策】
A. 指定ポートでアクセスできない
指定ポートがブロックされていないこと、別のアプリケーションなどで利用されていないことを確認してください(LDAPSのデフォルトポート番号は636)。
参考: Endpoint Centralが使用するポート番号
<手順>
- Endpoint Centralがインストールされているコンピュータ―上でPowershellを起動します。
- 次のコマンドを入力して、指定したドメインコントローラーにアクセスできるかを確認します。
Test-NetConnection <ADドメインコントローラーの IP/FQDN> -Port <ポート番号>
(例) Test-NetConnection 192.168.100.100 -Port 636
B. SSL証明書がActive Directoryにインストールされていない
SSL証明書がActive Directoryにインストールされているかどうか確認してください。インストール手順はMicrosoftのこちらのページを参照してください。
加えて、Endpoint CentralサーバーとCAの信頼関係を確認してください。Active DirectoryにインストールされたSSL証明書が社内認証局などの場合、ルート証明書をEndpoint Centralに追加して信頼する必要があります。
- こちらのページを参照して、Endpoint CentralサーバーにCAのルート証明書を追加し、Endpoint Central サーバーとの信頼関係を有効にしてください。
- 追加するドメインとEndpoint Centralサーバーが異なるフォレストに所属している場合、フォレスト間で双方向の信頼関係があることを確認してください。
- ネットワークごとにフォレストが存在している場合、各フォレスト間で双方向の信頼関係があることを確認してください。フォレストの信頼関係の作成方法はこちらのページを参照してください。(LDAPSの詳細につきましては、Microsoftへお問い合わせいただけますと幸いです。)