ネットワークパスが見つかりません
作成日:2020年5月19日 | 更新日:2025年5月26日
エージェントインストールに関するその他の問題については、エージェントインストールが失敗するをご覧ください。
「ネットワークパスが見つかりません」
問題
Patch Manager Plusエージェントのインストール、パッチスキャンを実行しようとすると、「パスが見つかりません」 (「Network Path was not found」 または 「ネットワークパスが見つかりません」)というエラーが発生します。
原因
次の状況で、このエラーが発生します。
- 管理対象PCがダウンしている、もしくは管理対象PCにアクセスできない
- 「ファイルとプリンタ共有」が管理対象PCのネットワークアダプターで有効化されていない
- Microsoftファイアウォールがプロセスを遮断している
- サードパーティ製ファイアウォールがプロセスを遮断している
- 管理対象PC上のAdministrative Share (Admin$)が無効化されている
- エージェントインストール
Active Directoryドメインベースのネットワーク環境において、コンソール画面からのエージェントプッシュインストールに失敗した場合は、スタートアップスクリプトを使用してのエージェントインストールもお試しください。 - パッチスキャン
手動パッチスキャンは、本ページの内容以外の様々な要因により処理に失敗する場合もあります。そのため、予めスケジュールパッチスキャンを設定します。
解決策
1. 管理対象PCにホスト名を使用してアクセスできることを確認する
管理対象PCの電源がONになっており、エージェントインストール、パッチスキャン、リモートコントロール、資産スキャン等の操作が実行できるよう、ネットワーク接続が適切に行われていることを確認します。また、正しいコンピューター名(ホスト名)が入力されていることも確認します。管理対象PCのアクセシビリティを確認するために、次の手順に従ってください。
- 「スタート」>「名前を指定して実行」を開きます(Windowsキー + Rキーでも可能)
- "\\"をプレフィックスとしてコンピューター名を入力します
\\PC_Name
- 「Enter」キーを押します
ping <Host_Name> を実行しご確認ください。
2. 「ファイルとプリンタ共有」を有効化する
管理対象PC上でエージェントのインストール、パッチスキャン、インベントリスキャン、リモートコントロール等のリモート操作を実行できるように、次のようにすべての管理対象PCで「Microsoftネットワーク用ファイルとプリンタ共有」を有効化します。
Windows7/8/10:
- 「スタート」>「コントロールパネル」を選択します
- 「ネットワークとインターネット」を選択します
- 「ネットワークと共有センター」を選択し、「共有の詳細設定の変更」を選択します
- 「ファイルとプリンターの共有」で、「ファイルとプリンターの共有を有効にする」を選択します
- 変更を保存します
Mac OS
- Appleメニュー > システム環境設定 > 共有 を選択します
- ファイル共有、リモートログインにチェックを入れます
3.Windowsファイアウォールを設定する
Windowsファイアウォール関連の問題が発生する場合、グループポリシーにおいて除外が許可されていないことが原因です。
この問題を解決するには、Patch Manager Plusサーバーの135/139/445ポート経由でのPatch Manager Plusエージェントへの通信を許可するようGPOを変更します。
4. サードパーティ製ファイアウォールの設定を変更する
すべての管理対象PCにおいてエージェントのインストール、パッチスキャンの操作が実行できるようファイアウォールを変更します。
5. 管理対象PC上で管理共有(隠し共有、"Administrative Share")を有効化する
Patch Manager Plusアプリケーションは、エージェントインストールを開始させる前にエージェント/配信サーバーのバイナリを対象PCの管理共有フォルダーである「Admin$」にコピーします。そのため、エージェント/配信サーバーのインストールを円滑に行うためは、クライアントマシン上でAdmin$を有効にする必要があります。
初期設定の管理共有を有効化するには、レジストリを以下のように編集します。
(参考)管理共有がない場合に発生する可能性がある問題の概要(Microsoft)
- UACによるリモート接続の許可(Windows Server/Windowsクライアント共通)
- Windowsスタートメニュー →「コントロールパネル」→「ネットワークと共有センター」→「共有の詳細設定」→「ファイルとプリンターの共有」において「ファイルとプリンターの共有」を有効化します。
- Windowsスタートメニュー →「regedit」と入力し、レジストリエディタを開きます。
- 次のレジストリハイブに移動し、「REG_DWORD値」を「1」に変更します
Hive: HKEY_LOCAL_MACHINE
Key: SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
Name: LocalAccountTokenFilterPolicy
Data: REG_DWORD
Value: 1 - 対象PCを再起動します。
- Windows Server
- Windowsスタートメニュー →「regedit」と入力し、レジストリエディタを開きます。
- 次のレジストリハイブに移動し、「REG_DWORD値」を「1」に変更します
Hive: HKEY_LOCAL_MACHINE
Key: SYSTEM\CurrentControlSet\Services\LanManServer\Parameters
Name: AutoShareServer
Data Type: REG_DWORD
Value: 1上記場所のレジストリにこの値が存在しない場合、新しい値を追加する必要はありません。レジストリ編集後、システムを再起動すると、変更が有効になります。 - 対象PCを再起動します。
- Windows クライアントコンピューター
- Windowsスタートメニュー →「regedit」と入力し、レジストリエディタを開きます。
- 次のレジストリハイブに移動し、「REG_DWORD値」を「1」に変更します
Hive: HKEY_LOCAL_MACHINE
Key: SYSTEM\CurrentControlSet\Services\LanManServer\Parameters
Name: AutoShareWks
Data Type: REG_DWORD
Value: 1上記場所のレジストリにこの値が存在しない場合、新しい値を追加する必要はありません。レジストリ編集後、システムを再起動すると、変更が有効になります。 - 対象PCを再起動します。