Endpoint Central オンプレミス版 ナレッジベース

Red Hatパッチ管理におけるトラブルシューティング


この記事では、Endpoint Central(Desktop Central)を使用してRed Hat Enterprise Linuxのパッチ管理を行う際に発生しうるトラブルの原因と対処方法について説明しています。
なお、Red Hat Enterprise Linuxパッチ管理のアーキテクチャーについてはこちらのナレッジをご確認ください。

既知の不具合や、Red Hatタグのついた各記事も合わせてご確認ください。

 
 

依存パッチがパッチリポジトリに存在しない

問題

配布するパッチに未ダウンロードの依存パッチ(依存ファイル)がある場合、1回目の配布ではステータスが「失敗」になります(※ビルドによって挙動が異なります)。
詳細はこちらをご覧ください。

原因

※ 製品の仕様となり、再試行または2回目以降の配布において成功すると考えられます。配布の実行をお待ちください。

解決策

こちらをご覧ください。


アカウントにアクティブなRed Hatサブスクリプションがない

問題

Red Hat コンピューターへのパッチスキャンや、パッチのダウンロード、パッチ配布の際に「アカウントにアクティブなRed Hatサブスクリプションがありません」というエラーメッセージが表示され、失敗します。

原因

(Red Hatサブスクリプションの形式が従来の形式の場合)入力したRed Hatアカウントには、アクティブなサブスクリプションがないか、サブスクリプションのステータスが「不明」です。
(Red Hatサブスクリプションの形式がSCAの場合)SCAに対応していないEndpoint Centralのビルドを使用しています。

解決策

(Red Hatサブスクリプションの形式が従来の形式の場合)
Red Hatポータルからアップデートファイルを受信するには、アクティブなサブスクリプションが必要です。Desktop Centralに入力したRed Hatアカウントに現在アクティブなサブスクリプションがあることを確認してください。
Red Hatターミナルで「sudo subscription-manager status」コマンドを実行し、システムのサブスクリプションステータスを確認します。
(Red Hatサブスクリプションの形式がSCAの場合)
Endpoint Central 11.3.2400.33 以降において、SCA (Simple Content Access) 形式のサブスクリプションに対応しています。そのため、Endpoint Central 11.3.2400.33以降のビルドへアップグレードします。

SCA (Simple Content Access)形式のサブスクリプションとは
Red Hat が導入した新しいサブスクリプション管理モデルです。詳細はhttps://access.redhat.com/ja/articles/6098461をご覧ください。

ダウンロードに必要な権限がない

問題

「ダウンロード許可が必要です。組織の管理者に連絡してください。(Download permission required. Contact organization admin.)」というエラーメッセージが表示されます。

原因

Endpoint Central(Desktop Central)に入力した資格情報には、パッチのダウンロードに必要な権限がありません。

解決策

Red Hatアカウントの組織管理者に連絡して、ダウンロード許可をリクエストしてください。


指定システムからRed Hatポータルにアップロードできない

問題

指定システムからRed Hatポータルにファイルをアップロードできません。

原因

Endpoint CentralエージェントからEndpoint Centralサーバーにアクセスできません。以下の原因が考えられます。

  • Desktop Centralサーバーが停止している
  • サーバーのIPアドレスが意図せず変更された
  • サーバーを別のコンピューターに移行した
  • サーバーとの通信がファイアウォールでブロックされている
解決策

こちらのナレッジを確認し、エージェントとサーバー間の通信が正常に行われることを確認します。


https://access.redhat.com/downloadsにアクセスできない

問題

「https://access.redhat.com/downloadsに到達できません」というエラーメッセージが表示され、Red Hatパッチのダウンロード・配布が失敗します。

原因

Red Hatカスタマーポータルへのログインに必要な証明書ファイル「cacerts」が、DesktopCentral_Server\lib\downloadToolに存在しない場合、このエラーが発生します。
Red Hat がカスタマーポータルの挙動を変更したり、URLを変更した場合に発生することがあります。

解決策
  1. cacertsファイルが指定された場所(DesktopCentral_Server\lib\downloadTool)に存在し、使用可能であることを確認します。使用できない場合は、指定された場所にダウンロードして配置します。
  2. ネットワーク接続を確認して、Red Hatカスタマーポータルにアクセスします。
  3. Red Hat がカスタマーポータルの挙動を変更したり、URLを変更したことによる問題である場合、日本国内向けEndpoint Centralの最新版へアップグレードするか、サポートまでお問い合わせください。

指定システム(Nominated System)におけるキャッシュリポジトリの作成におけるトラブル

問題

「Red Hatポータルから指定システムにファイルをダウンロードできません。」 「Desktop Centralサーバーにファイルをアップロードできません」といったエラーメッセージが表示されます。

原因

次の原因が考えられます。

  • (a) ファイアウォールに制限されているかインターネット接続がないため、指定システムがRedHatカスタマーポータルにアクセスできません。
  • (b) 指定システムにEndpoint Centralエージェントがインストールされていません。
  • (c) RedHatカスタマーポータルとの通信に必要な「sslclientcert」という名前の証明書が無効/欠落しています。
  • (d) 指定システムに、TLSセキュリティを変更する透過プロキシが含まれている場合があります。
  • (e) 指定システムのシステムクロックが正しくない可能性があります。
  • (f) Red Hat がカスタマーポータルの挙動を変更したり、URLを変更したことにより、ご利用中のビルドのEndpoint Centralが対応できない問題が発生している可能性があります。
解決策

原因に対応する解決策を実行します。

  • (a) インターネット接続が機能していることを確認してください。
  • (b) 指定システムにエージェントをインストールします。
  • (c) サブスクリプションを一旦指定システムから削除し、再度サブスクリプションを有効化します。
  • (d) TLSセキュリティ構成を変更するようなプロキシがないことを確認してください。
  • (e) 指定システムのシステムクロックが正確かつ最新であることを確認してください。
  • (f) 日本国内向けEndpoint Centralの最新版へアップグレードするか、サポートまでお問い合わせください。

上記の手順を実行しても問題が解決しない場合は、お問い合わせください。サーバーログ および 「管理」タブ →「Red Hat設定」画面のスクリーンショットのアップロードをお願いする場合があります。


Yumが既に実行されているため、スキャン/配布が続行できない

問題

スキャン中または配布中に「Yumが既に実行されているため、スキャン/配布を続行できません」(Cannot proceed with scan/deployment since Yum is already running)というエラーメッセージが表示されます。

原因

以下の原因が考えられます。

  • ユーザーがソフトウェアのインストールをちょうど開始した
  • RedHat自動更新(yumbackend.py)が実行中
解決策

ユーザーがソフトウェアのインストールを完了するのを待ちます。
RedHat自動更新が実行中の場合は、自動更新を無効にします。