「800706BA - RPCサーバを利用できません。」
作成日:2013年6月3日 | 更新日:2025年1月8日
現象
WMIの認証に失敗し、以下のメッセージが表示される。
「800706BA - RPCサーバを利用できません。」
原因
このエラーは、RPCおよびWMIサービスが作動していない、または装置と、pingによる疎通ができない、DNSの正引きまたは逆引きのいずれかが正しくない場合等に発生します。
解決方法
1)装置が起動していて、pingに応答することを確認
2)「Remote Procedure Call(RPC)」と「Windows Management Instrumentation(WMI) サービス」が作動していることを確認
<手順>
- [スタート] > [ファイル名を指定して実行]を選択します。
- テキストボックス内に services.msc を入力後、[OK]をクリックします。
- サービスの一覧内のRPCとWMIサービスの状態が開始になっていることを確認します。
- サービスが開始されていない場合には、サービスを開始します。
3)リモートコンピュータ上でファイアウォールが設定されている場合
WindowsでデフォルトのWindowsファイアウォールが有効になっているとき、このような例外が発生します。
無効化するには、次の手順を実施します。
<手順>
- [スタート] > [ファイル名を指定して実行]を選択します。
- Firewall.cpl を入力後、[OK]をクリックします。
- [全般]タブ内で[無効]をクリックします。
- [OK]をクリックします。
4)ファイアウォールがWMIのトラフィックをブロックしている場合
ファイアウォールのWMIトラフィックのアクセスを許可します。
<手順>
- ファイアウォール内の135ポートをopenにします。
- ファイアフォールの設定で次の受信設定を有効化します。
・Windows Management Instrumentation(DCOM受信)
・Windows Management Instrumentation(WMI受信)
5)WMI認証に成功しているが、Windowsサービスを登録しようとした時に本メッセージが表示される場合
この場合、名前解決が出来ていない可能性が考えられるのでOpManagerインストールサーバーのhostsファイルにホスト名とIPアドレスを登録します。
OpManagerインストールサーバー上でコマンドプロンプトを使用し以下のコマンドを実行します。
- nslookup <対象装置のFQDN>
- nslookup <対象装置のIPアドレス>
上記どちらかの結果が正常でない場合、OpManagerのログ(stderr.txt)には以下が記録される場合があります。
800706ba - The RPC server is unavailable: While getting WMI data from <IPアドレス> for SELECT Version,Caption,ProductType FROM Win32_OperatingSystem
また、パケットキャプチャでは以下のエラーパケットが表示される場合があります。
KRB Error:KRB5KRB_AP_ERR_MODIFIED
対象装置のDNS設定を見直して問題を解決します。
【対応リリース】x.x
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OpManager 製品紹介ページはこちら ↓
https://www.manageengine.jp/products/OpManager/
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