OpManager ナレッジベース

アップグレード後にファイル整合性機能で「sum.bat」が検出される場合の対応方法


本事象の原因となる不具合は、ビルド12.8.272で修正されました。
最新版へのアップグレードを行っている場合は、本事象は発生しません。

原因

OpManagerの不具合により、ビルド12.7.124および12.7.198へのアップグレード時にデータベース上の「sum.bat」のチェックサムが更新されず、アップグレード完了後にファイル整合性機能により、改ざんされた可能性のあるファイルとして検出される場合があります。

対応方法

以下の手順を実施してください。

  1. ビルド12.7.124である場合はビルド12.7.198にアップグレードします。
    何らかの事情でビルド12.7.198にアップグレードできない場合は、本ナレッジを確認した旨を添えてサポート窓口までお問い合わせください。
  2. ビルド12.7.198用修正パッチをダウンロードし、解凍します。
  3. OpManagerのサービスを停止します。
  4. OpManagerインストールディレクトリ/lib/fix配下に手順1で解凍したcomフォルダーを配置します。
    ※配置後のパスは以下の通りです。
    OpManagerインストールディレクトリ/lib/fix/com/adventnet/netflow/flow/collector
  5. OpManagerのサービスを起動します。
  6. [設定]→[一般設定]→[セキュリティ設定]→[ファイル整合性]タブ→[スキャン 即時]をクリックします。
  7. [ファイル整合性]のページで「sum.bat」が検出されなくなったことを確認します。
    上記手順を実施後も事象が解消しない場合は、サポート窓口までお問い合わせください。