OpManager ナレッジベース

監視対象の装置に対してのSNMP認証に失敗する


概要

監視対象の装置に対してのSNMP認証に失敗する場合の、考えられる主な原因と解決方法をご説明します。

目次

原因

主に以下のような原因が考えられます。

  • 監視対象側でSNMPエージェントを起動していない
  • 監視対象側でSNMPパケットを受け取るホストを制限している
  • OpManager上でのSNMPの認証設定が誤っている
  • ファイアウォール等が原因で、SNMPで利用する161番ポートが利用できない状態になっている

解決方法

※確認ビルド:12.4.062以上
ビルド番号の確認方法はこちら

監視対象の装置上でのSNMP設定の確認

下記のナレッジを参照し、設定値に不備がないか確認をお願いいたします。

・監視対象装置のSNMP設定を確認する方法
https://www.manageengine.jp/support/kb/OpManager/?p=15625

OpManager上のSNMPの認証設定の確認

以下の手順にて、OpManager上のSNMPの認証情報が正しく、かつ対象装置に関連付けられているかを確認します。

  1. [設定]タブ→[ディスカバリー]→[認証情報(認証設定)]に移動します。
    ※ご利用のビルドによっては、画面の表記が異なる場合がございます。
  2. SNMP認証に失敗している装置が利用している認証情報をクリックし、編集画面を開きます。
  3. コミュニティ名などの詳細を正確に入力し、[保存]をクリックします。
  4. [インベントリ]タブにて、SNMP認証に失敗している装置をクリックし、装置の概要ページに移動します。
  5. [装置概要]から[認証設定の変更]をクリックします。
    ※ご利用のビルドによっては、画面の表記が異なる場合がございます。
  6. [SNMP認証]にて、手順3で編集した認証情報を選択し、[認証テスト]を実施します。
  7. 成功した場合、[OK]をクリックし、認証情報を装置に関連付けます。

監視対象装置のポート161番がブロックされていないかの確認

OpManagerの認証設定、装置側のSNMPの設定共に問題が無い場合、
ファイアウォール等が原因でSNMPで利用する監視対象装置のポート(161番)がブロックされている可能性がございます。

OpManagerサーバー側では、動的ポートが使用されます。
使用ポートはこちらをご参照ください。
実際にSNMPのパケットを受信できているかどうかを確認するには、Wireshak等のパケットキャプチャが有効です。

上記確認後も解決しない場合

保守サポートへお問い合わせください。
お問い合わせいただく場合は、本ナレッジを参照した旨や、実施した確認事項をご連絡ください。
いただいた情報を元に、原因調査を行わせていただきます。