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構成のステータスが「未適用」のまま、構成が適用されない


構成のステータスが「未適用」のまま、構成が適用されない

問題

パッチ配布構成やソフトウェア配布構成、構成機能の各構成を配布しても、実行ステータスが「未適用」(ビルドによっては「未だ適用されていない」の表記となる場合があります) のまま変わらず、配布が実行されません。
 

原因

次のような理由が考えられます。

配布ポリシーの設定内容によっては、配布実行そのものに時間を要する場合があります。
配布ポリシーの設定方法については、配布ポリシーの設定方法をご覧ください。

 


解決策
「構成」タブ で構成一覧を表示させ(「すべてのユーザーが作成」を選択)、各構成名 → 「実行状態」を開き、「備考」列の表示内容から、原因が分かる場合があります。

1. エージェントと通信できない、エージェントがブロックされている、エージェントの更新に失敗している

Endpoint Central Cloudとエージェントの通信に問題がある場合や、エージェントが起動していない場合、またはエージェントのインストール・更新に問題がある場合などエージェント自体に問題が発生している場合、構成の実行が開始されない可能性があります。
Windowsエージェントの場合、エージェントトラブルシューティングツールを実行して状況を確認してください。必要に応じて通信の問題を解決します。
なおエージェントトラブルシューティングツールの実行にも問題が発生する場合、アンチウイルスソフトやEDR、セキュリティポリシー等によってエージェントの動作がブロックされている可能性や、エージェントのインストール・エージェントの更新に問題が発生している可能性があります。

 

2. スケジュールの開始時刻を待っている

Endpoint Central Cloudの構成では、複数のスケジュールに関する設定があります。指定した条件をすべて満たすまで構成は開始されません(「今すぐ配布」よりも設定されたスケジュールが優先されます)。
以下にあるようなスケジュール設定の内容を確認してください。

配布ポリシー で指定した配布期間または配布のタイミングまでまだ時間がある

手動配布構成のスケジュール設定で「~後にインストール」を選択している
指定時刻より後に配布するような設定を行なった場合、設定は指定時刻になるまで「未適用」の状態となります。

 
システム起動時のみ・ユーザーログオン時のみに配布される設定である
システム起動時のみ・ユーザーログオン後のみに構成を配布するような設定をした場合、リフレッシュサイクルや「構成の適用」では適用されません。
システム起動・ユーザーログオンをお待ちください。
 

指定日に配布される設定である
配布ポリシー」に指定された期間内に配布は行われます。配布を行う日・曜日・期間を指定している場合、構成はその指定日になるまで開始されず「未適用」の状態となります。
 

配布に必要なファイルの準備中に、配布ポリシーで指定した時間帯を過ぎてしまった
配布対象のパッチやソフトウェアに依存ファイルがある場合などは、必要なファイルをダウンロードするためにかかる時間が長くなります。また、ベンダーサイトによっては回線が混雑し、ダウンロードにかかる時間が長くなることがあります。「配布ポリシー/設定」に指定された期間内が比較的短く、期間の直前に配布を構成した場合、ダウンロードが期間内に終わらないことが考えられます。この場合、配布ポリシーで指定した次の期間になるまで設定は「未適用」の状態となります。
 

MS Officeのパッチの場合、Officeアプリケーションが使用中である
MS Officeのパッチの場合、アプリケーションの使用中はパッチを適用することができません。Office Click-to-Run設定を確認し、パッチ配布時にアプリケーション使用中だった場合の挙動を見直します。
 

配布ポリシーの時間帯指定について
配布ポリシーにおける「配布ウィンドウ」の時間帯指定は、最低リフレッシュサイクル2回分の180分の時間が必要ですが、特段の理由が無ければ長い時間帯を設定することをお勧めします。
(例)00:00~23:59
3. 他の構成の完了を待っている

他の構成が適用中の状態では配布を実行できず、他の構成の完了まで待ってから配布が開始される場合があります。
こちらのPointを参考に「備考」列の表示内容を確認し、完了まで待ちます。

4. ユーザーが配布を延期している

配布ポリシー等においてユーザーに配布の延期を許可している場合、ユーザーは構成の開始を延期できます。ユーザーが延期している状態では、構成は「未適用」と表示されます。
 

5. 配信サーバーに到達できない

配布対象のコンピューターが配信サーバーのあるリモートオフィスに設置されている場合、構成の適用は配信サーバー経由で行われます。
構成情報は複製ポリシーにしたがってEndpoint Central Cloudから配信サーバーに複製されるため、レプリケーション間隔が長い場合、配信サーバーへ複製されるまで時間がかかる場合があります。
また、Endpoint Central Cloudから配信サーバーに到達できない場合にも、その配信サーバーが配置されているリモートオフィスへの構成ステータスは「未適用」となります。

配信サーバーが設置されているリモートオフィスに所属するエージェントからトラブルシューティングツールを起動することで、配信サーバーの接続状況を確認できます。

配信サーバーがEndpoint Central Cloudから構成情報を取得できていることを確認します。

  1. Endpoint Central Cloud にログインし「エージェント」タブ →「管理対象」→「リモートオフィス」に移動します。
  2. DSコンピューター名(DS=Distribution Server, 配信サーバーの略称です)横のステータスおよびDSの最終接続時刻から、接続ができていることを確認します。
  3. 何らかの理由で複製が失敗した場合、サポート情報よりエラー内容を参照します。Endpoint Central Cloud配信サーバーのログを添えて、弊社サポートまでお問い合わせください。

 

6. Active Directoryドメインコントローラーに到達できない

構成の対象として、カスタムグループ・Active Directoryドメイン・OUを指定している場合、ドメインコントローラ―に管理対象コンピューターから到達できない場合、構成は「未適用」の状態となります。
Active Directoryドメインコントローラーに管理対象コンピューターからアクセスできることを確認してください。
 

7. 配布時にコンピューターが指定対象から外されている

構成の配布対象として カスタムグループやActive Directoryドメイン、OUなどを指定可能です。
カスタムグループやドメインなどに所属していたコンピューターの一部が、配布開始直前にそのグループから離脱した場合や、配布の構成対象としてコンピューターを選択し、そのコンピューターの名前が変更された場合、それら対象が見つからなくなるため、配布ステータスは「未適用」のままになる場合があります。

8. Endpoint Central Cloudに障害が発生している

Endpoint Central Cloudの可用性をご確認ください。
 

以上の点を確認しても問題が改善しない場合、エージェントログ構成のエクスポートを添えてサポートまでお問い合わせください。
(なお、適用まで時間を要しているだけであった場合、時間が経つと問題が自動的に解消されている場合があります)